"AVR.duino U+" Documentation Requests
  • Let us know where our documentation of this product is lacking in this discussion. We will use your comments to update and improve our documentation.

    Please do not expect answers to questions here; please create a new discussion when looking for answers. Comments here should be something like: "It would be good if you explained blah blah better.", or, "I think this may be a common question: What is blah? The answer I discovered was blah dee blah.", or, "My question is this: How do I do blah? and I still haven't found an answer to it but I've started a discussion looking for an answer here-> (link)"

    Thanks for helping to improve our documentation!

  • Hello new to this.

    I have not seen any documentation, the only thing I see is a link to Arduino on the main page.

    I have followed the getting started with Arduino, but it seems Win7 is not recognising this board as it is specified in the getting started. When I connect the board to the usb port, according to the begining document, I should see a com port with Arduino so I can install the driver. "Look under Ports (COM & LPT). You should see an open port named "Arduino UNO (COMxx)" However, i do not see any additional com port.

    need help. Is this board compatible with the Asduino?

  • Hey Garbo,

    Sorry for the late reply, I needed to find a Win7 machine where the Arduino tools hadn't been installed yet.

    The short answer is that it will appear under "Other devices -- Unknown device".

    Right click on Unknown device, choose "Update driver..." and follow the rest of the instructions. I'm guessing whoever wrote the instructions on Arduino.cc wasn't working with a virgin (in the Arduino installation sense) system since it can't be assigned to a COM port until after the driver has been installed.

    Your experience with AVRduino U+ will be identical to Arduino Uno Rev3. In fact I verified with an actual Arduino Uno Rev 3 that it also appears as "Unknown device" just to be sure.

    Let me know if this solves your problem.

    Thanks,

    Jake.

  • Thanks for the reply.

    It did work as you instructed. I have already uploaded few basic sketches and works flawlessly.

  • I'm new to the arduino and small electronics. It would be good to have a top down shot of the AVRduino U+ with a description of all the pins and how it differs from an Uno R3. One thing I've found already is that on the Uno R3 the analog pins A4 and A5 are able to be a serial SCL and SDA connection while the AVRduino U+ does not have the A4 and A5 serial connection as far as I can tell. The serial connection is located as the last two pins above the row of digital pins. If you have a shield that uses the A4 A5 serial connection, then you will have to rewire things to try and get it working.

    Of course I may be wrong and that's why it would be great to have better documentation of whats what on the board.

  • @bpcomp,

    Short answer: AVRduinoU+ has the Rev3 SCL and SDA connections you are looking for. All the pins on the Arduino Uno Rev3 are available on AVRduino U+ and are identical in function.

    I like your suggestion and will add another photo with the new additions pointed out and the SDA and SCL labels that you cannot see.

    But until then:

    Click on the photo of the bottom side of the board. The photo will be enlarged and you will see the SCL and SDA labels at the top right side (I admit they are a bit difficult to see).

    Also, open the AVRduinoU+ schematic. Along the right side near the bottom you will see that SDA and SCL are connected to JF1 and up above you will see the same SDA and SCL labels on pins 27 and 28 of the microcontroller which correspond to ADC4 (A4) and ADC5 (A5). Note that wires with the same labels in a schematic are connected together on the printed circuit board (PCB).

    Also, in the product features section note the bullet:

    • has the extra connections of the Rev3 board (SDA, SCL, and IOREF) making it compatible with the latest Arduino Shields

    Also check out the AVRduinoU+ Quickstart video to see the board in action.

    Thanks for the feedback, let me know if this answers your questions,

    Jake

  • I guess that does answer the question but I wonder what I'm doing wrong with the MPR121 breakout board from sparkfun. https://www.sparkfun.com/products/9695

    It was completely unresponsive on A4 and A5 yet worked on the additional serial pins. Until I can test further I'll assume it is a user error issue on my part.

    On another question, what is the sort of gummi stuff on the bottom of the board that covers A6 and A7? Is it just a removable protection or something else?

  • @bpcomp,

    It is possible that you got SDA and SCL flipped around. If you have an ohm meter you can verify to yourself that A5 (right most pin on bottom) is connected to SCL (left most pin on top). And that A4 (next one from right on bottom) is connected to SDA (next one in from left on top).

    You guessed right. That green rubber-like stuff on the bottom of the board is peel-away solder mask. It prevents solder from getting into holes or onto solder pads when the boards pass through the solder reflow machine when they are manufactured. Grab the corner of it with your finger nail and peel it off if you like. Without it, the A6 and A7 holes would fill with solder and you would have to use a solder sucker or solder wick to remove the solder before you could solder in your own connections.

  • I bought a power supply that was supposed to be 9v at 650ma. I ran one of my AVR.duino U+ for a couple hours running a couple RBG leds and now my board is dead and won't respond. Can't reprogram it. I decided to test the supply and it is putting out 11.64v. Is it possible that I fried the board with my supply?

  • @bpcomp,

    It is unlikely that a 12V supply would have caused any harm. It is more likely that you may have been drawing too much current through the LEDs.

    Here are some steps to try:

    • make sure the board is on a non conductive surface (like cardboard or paper or wood)

    • remove your LED circuit and try powering up with a USB cable only (power supply disconnected).

    • does the green power LED (just to the right of AVRduino U+ on the board) come on at all?

    • did you have both the USB and the power supply connected when you left it running?

    • what values of series resistor did you use between the AVRduino and the RGB LEDs? If you did not have current limiting resistors that would be a problem that may have caused harm.

    • verify that your power supply is positive on the inside of the barrel and ground on the outside (put black of voltmeter on outside red of voltmeter on inside) and verify it reads +12V and not -12V. Unlikely if it was previously working.

    Jake.

  • Board on a non-conductive surface: Check

    Circuit removed and powering with USB cable only: Check

    Does the green power led come on: Check

    Were both USB and DC power plugged in at the same time: No, only DC.

    Resistor was 330 Ohms.

    Power supply is correctly wired but putting out wrong voltage.

    If I try to upload the example blink sketch, the RX led blinks 3 times and then I get this error.

    Binary sketch size: 1,084 bytes (of a 32,256 byte maximum) avrdude: stk500_recv(): programmer is not responding

    Serial port is double checked and works fine with my other AVR.duino U+

  • @bpcomp,

    Sorry I didn't realize you had another AVRduino to compare against.

    If you have a voltmeter you can check what the output of your supply is with a 1K resistor attached between the meter leads. Switching power supplies often display higher voltages under un-loaded conditions.

    You can also plug it into the AVRduino and measure the voltage on header pins VIN and 5V (while not connected to USB) to verify that the voltages are okay.

    Assuming those are okay the most likely cause of it not working would be something got shorted out somewhere or too much current was drawn from a pin. If you would like to mail it back for evaluation you can do that. Send an email to support at slicmicro dot com.

Search

Welcome to our Forums!

To take part in the discussions, sign in or apply for membership below.

Discussion Forums